Dao350.dll failed to register

RFguy

New member
Joined
Jul 13, 2002
Messages
3
I am trying to load v 1.7, on install I get the 'Dao350.dll failed to register ' error.

Though 1.7 seems to load, after restart, my system is never able to reboot due to a problem with MSHTML.DLL

I am running on a new hard drive with a fresh copy of Win98 SE, with all the critical updates.

Any Ideas??
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Build 40 was just released approximately two hours ago, so if it's the one you got Thursday, that was build 30 and obsolete now.

Please click download.logbookpro.com and download the new build and give it a shot. Prior to installing, uninstall the old build from Start...Settings...Control Panel Add/Remove programs. Reboot, then go to C:\Program Files\Common Files\Microsoft Shared\DAO and delete DAO350.DLL and the .TLB file. Then install the build you are about to download and see if that resolves your issue.

If you are also having problems with MSHTML, I have a feeling you may have a bad OS install. Make sure you have all Windows Updates installed AND Internet Explorer 6 and that may help fix your other OS issues, which may in turn resolve the Logbook Pro install issue as well.

Neal Culiner
NC Software, Inc.
support@nc-software.com
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
I just ran an install against a clean Win98_SE and I too am seeing the error now! You should get the option to Abort...Retry...Ignore. Just click Ignore and it will get past this and work fine. I'm reviewing the installer and will upload a new installer as soon as I pin this one down. This is not critical as the software is still installing fine, I just have to find the conflict.

Thanks for reporting this.

Neal Culiner
NC Software, Inc.
support@nc-software.com
 

RFguy

New member
Joined
Jul 13, 2002
Messages
3
That is the same thing that happened to me,... I also ignored and program seemed to work just fine....until restarting Win98 again.....


on the restart i had the problem with MSHTML.DLL Which rendered my OS inoperable.... had to do a recovery op.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
This error is in no way associated to MSHTML. DAO is one DLL that only deals with data access and really has NO impact on your operating system. I would strongly recommend you install Internet Explorer 6 and all the Windows Updates prior to doing anything else, i.e. installing the very first application on your computer.

Internet Explorer is a way Microsoft sneaks in 'fixes' to the OS as well as the web browser enhancements. The OS these days is essentially becoming IE.

I am reviewing/rebuilding the installation routine today, testing to see why this error all the sudden is appearing for the first time, and will reupload a new installer once I have this resolved. This is not critical and will not require anyone to reinstall, it will still be build 40, just with an updated installer to prevent this issue. I'll post a reply here when the new installer is ready.

Neal Culiner
NC Software, Inc.
support@nc-software.com
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
A new installer is now live on the servers, same URL as before. I did change one setting on the DAO350.DLL file and how it's registered on the system and this has resolved this issue. I have tested this on clean installs of all OS's and it checks good. This issue was in no way severe nor would it cause Logbook Pro to fail.

1.7.40 is certified and good to go! Enjoy!

Neal Culiner
NC Software, Inc.
support@nc-software.com
 
Top