Date formats mixed when exporting

jsollows

Member
Joined
Oct 11, 2003
Messages
23
When I export my log to Excel the dates come out in different formats. For example here are the first 6 log entries. They were all in July 2000. Notice that in the first 2 entries the format is MM/DD/YYYY and in the last 4 the format is DD/MM/YY



<COLGROUP>
<COL style="WIDTH: 65pt; mso-width-source: userset; mso-width-alt: 3145" width=86>


07/01/2000

07/08/2000

18/07/2000

23/07/2000

29/07/2000

31/07/2000


This is replicated throughout the log with the date formats flip flopping. Strange thing is that they all display correctly inside Logbook Pro. Any idea how to correct this?


Jim
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,573
Location
VA
Jim,


I'm assuming the short date format on your system is probably DD/MM/YY? You can check this in the Windows Control Panel Regional Settings area.


I'm guessing that the dates are in fact correct as you have them listed. Are they:


7 Jan 2000
7 Aug 2000
18 July 2000


etc.? I believe all of the dates you listed appear in DD/MM/YY format. If this is not the case, create a backup of your logbook (File..Archive..Backup) and e-mail it to support with details on exactly what you are doing, i.e. what to export, how you're exporting, etc. and I'll take a look.


 

jsollows

Member
Joined
Oct 11, 2003
Messages
23
I think it is a problem with the link between Excel and LBPro. If I export the log to either text or csv, all the dates are fine as shown here...



Now if I export the log to excel, I get this ... notice the dates order and compare to above

If I just open excel and directly import the .csv file I created in the first step, all the dates are recorded correctly. This is what I am going as a work around.

Jim
 
Top