.dll and .ocx errors during new install

karickbiz

Member
Joined
May 18, 2005
Messages
5
I downloaded and installed the eval version and when it is almost complete with the install it displays five consecutive error messages:

Error 1904.Module C:\Program Files\Logbook Pro\lbRepts.dll failed to register...
Error 1904.Module C:\windows\system32\SmartUI2.ocx failed to register...

Error 1904.Module C:\windows\system32\AEpopup6.ocx failed to register...
Error 1904.Module C:\windows\system32\ssdw3b32.ocx failed to register...
Error 1904.Module C:\windows\system32\ssdw3a32.ocx failed to register...

I have tried doing a repair and same result. I have tried installing with firewall and anti-virus disabled.

Please help, Thanks

Rick
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Rick,

It sounds like there are some serious issues on your PC. I suggest ensuring you have all Windows Updates including the latest Internet Explorer installed. Do you have Microsoft Office installed on your system? It has many of the same dependencies as Logbook Pro and installing that may resolve whatever is missing or improperly configured on your PC. Please provide details such as which OS you have, etc.

 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Some other thoughts:

Have you made any changes to msconfig or any other system related configuration settings?

I don't have any suggestions as this issue is outside that of Logbook Pro support. This may end up requiring a reinstall of Windows to correct something critical missing on your system.

 

karickbiz

Member
Joined
May 18, 2005
Messages
5
I am running XPHome w/ SP2 with all the latest updates for Windows/IE and Office 2000 SP3. It's a AMD Athalon XP1800+ with 512MB RAM. So far I have no issues with other software. These kinds of errors are afirst on this system.I have a lot of software on this system.Are thereany known conflicts with other software found with LBP?


I'll give you any info you need tohelp me troubleshoot this issue, but I don't think i'll go as far as reinstalling XP. It is running well and I am pleased with the ~99% up time I am having with it, considering how much software I have on it. With that said, I am very willing to examine file versions, registry settingsand other items, if you are able to take the time.


Thanks for the rapid response,


Rick
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Rick,

Let's step through a few dependencies that may be problematic on your system. I'd like you to download and install the VB6 Runtime from the Microsoft Site here. After doing so, uninstall then reinstall Logbook Pro and see if you now get a successful install.

 

karickbiz

Member
Joined
May 18, 2005
Messages
5
OK I have installed the VB6 Runtime from Microsoft and the MDAC. I do have Admin rights.The same errors still occur. I am able to open LBP and it says it is creating a new data file. Whenthe question about updating the filefor "severeal new features" appears, if I click OK it completes the build (according to the progress bar at bottom left) but then locks "(Not Responding)" and I have to force windows to close the application. If I click cancel, the whole app. closes without doing anything. other ideas?


Rick
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
If you're still having this issue, try downloading this file from Microsoft, install, then retry the Logbook Pro installation. It appears a dependancy is missing in your OS and we need to figure out what is missing.

 
Top