Problems Updating LBP from 1.9.7 to 1.9.8.1

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
I'm having some difficulty updating LBP to 1.9.8.1. The installation program launches and does it's thing and then hangs at the following screen:

Logbook Pro is configuring your new software installation:

Removing Backup Files

The program stays in this screen but nothing further happens with the installation - forcing a three key Task Manager shutdown of the installation (which says it is still running by the way). I've tried this installation process several times using repair and modify instead of installation with the exact same results. Your suggestions are appreciated.

Nathan Alm
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello Nathan,

Please uninstall Logbook Pro from your computer using the Windows Control Panel Add/Remove programs area. It also good to do a reboot to ensure things are 'clean' prior to installing. Once uninstalled, go into C:\Program Files\Logbook Pro and rename the Logbook Pro folder to C:\Program Files\Logbook Pro OLD. Install 1.9.8.1.

 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
This seemed to work. Thanks for your help. Can I now remove the C:\Program Files\Logbook Pro OLD file away?
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
As long as your data file is not located in that folder (ends with .LBK) or your backup archives (.BAK files) you can remove that folder. The folder is the default location when first creating data files hence why I am skeptical in telling anyone to delete it. Backup your data file (File..Archive..Backup) then remove the old folder should be fine. I'd leave it in the Windows Recycle bin for a few uses of Logbook Pro just to play it safe prior to emptying the recycle bin.

 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
Morning all,


Long time user, first time to post a problem. Using Win2K, I removed 1.9.7. During the 1.9.8.1 install using the lbproNoMSI executable, the Install Shield Wizard hangs at "Searching for installed applications". Task manager indicates the wizard is still running, but CPU usage is zero. Clicking "Cancel" gets me an hourglass, but the install wizard refuses to terminate. Terminating thewizard via task manager gets a secondary "End Program" window saying that IDriver.exe is not responding, and offers to let me kill the process. I then get an error 1628 "Failed to complete installation".


If I thenattempt to re-install without rebooting, InstallShield reports an error 1607 "Unable to install InstallShield Scripting Runtime" and terminates.


After reading this thread, I double-checked that LBPro was no longer in the "installed programs" list under windows "Uninstall Software", and I renamed the Logbook Pro folder to "Logbook Pro_OLD". After rebooting and attempting a reinstall I get the same installation hang.


I'm a long-time user and a former network engineer, competent with Win2k, and have not had any problems using LBPro since my original purchase in early 2001.


Am I missing something?


Thanks in advance,


Richard Hall
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hi Richard,

I believe InstallShield is having some version conflicts with IDriver as I had problems on my system when installing the Palm Treo 650 software. Palm's web site had a support article about registering a different version of IDriver, but I don't think we need to go there! Let's make sure Logbook Pro is uninstalld, then install the InstallScript engine posted here. After that's done, reboot, then install 1.9.8.1 and see if it works out.

 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
Come on Neal, it took you a whole 4 minutes to respond to my question!

Will post back the results...

I love this software!
 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
Time for the next suggestion.


I double checked that LBP was not on the "installed programs" list, d/loaded and installed ISScript1050 (which installed perfectly), rebooted, and attempted the install of 1.9.8.1.

InstallShield Wizard still hangs at "Searching for Installed Applications".

Thanks in advance for your support,

Richard
 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
I'll give the Windows Installer Cleanup Utility a try. With regard to the scanning of the system, I let it run overnight last night (7+ hours). It's hung.

Will let you know if the Cleanup Utility uncovers anything. Thanks for your prompt replies!

Richard
 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
Unfortunately, the Windows Installer Cleanup Utility shows no traces of LBPro existing on the system. I rebooted and tried the install again, with the same results.

Next suggestion?

Richard
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Richard,

I'm out of suggestions here as I honestly don't know what's causing this issue. There are so many variables with installations and operating systems these days, your troubleshooting and guesses are as good as mine. I always suggest ensuring you have the latest service packs and windows updates for your OS.

I'd make a copy of your .LBK and .BAK files (data and backups) to a location such as C:\MyLogbook and then delete the Logbook Pro folder(s) (do not remove from recycle bin just as a last resort).

Confirm you have administrator permissions in Windows 2000?

Here is the information from the PalmOne site I had to use with my Treo software some time ago, maybe it can help.

Try using this file to install Logbook Pro.

 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
Wilco on the different LBP install file. Will let you know the results.

Administrator rights comfirmed.

Richard
 

rhallky

Member
Joined
Apr 6, 2005
Messages
9
The full LBP installer file halts at the same place :(

I've been racking my brain trying to think if I did anything unusual for this upgrade... The only difference was when I initially uninstalled LBP 1.9.7, I did so by using the executable which was installed in the LBP folder (Start->Programs->LogbookPro->Uninstall LBPro), rather than the windows 'Add/Remove Programs' package.

The uninstaller included with LBP appeared to do it's job... The desktop icon, folder under Start->Programs, and listing under windows 'Add/Remove Programs' all disappeared.

Is there a link on your website to older versions of LBP? 1.9.7 was stable and functioning; I was simply looking forward to trying some of the new features in 1.9.8.

Thanks for everything,

Richard
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Richard,

I'm researching with InstallShield. If you want, we may want to take this offline via e-mail to keep the others on the top of this thread from getting bothered. E-mail me at support@nc-software.com with the log file after following the procedure below and we'll go from there.

Uninstall Logbook Pro once again, if it's listed, and install using the sequence below to generate a log file. Something else is to ensure any anti-virus, anti-spyware, etc. is disabled. One other option that works on Windows 98/Me machines to ensure a clean boot up (which you'd have to do after logging on to Windows 2K) is once you have completed the logon, hold the SHIFT button down and keep it held down until Windows is completely loaded. This will prevent TSR's from loading which may be interfering with the installation.

To perform an installation with logging, click Start...Run then point to the lbpro.exe file (or lbroNoMSI.exe) file. At the end of the path, add:

/verbose c:\lbpro.log

So you should see something like:

c:\downloads\lbpro.exe /verbose c:\lbpro.log

Click OK to start the install, a log file should be created in the root of C.

E-mail that to me and we'll go from there. I will be in meetings for a few hours this afternoon and then check back and see if we can get this squashed!

 
Top