Report function not working

Joined
Jan 12, 2013
Messages
7
I finally decided to print out my logbook and put it into a binder. I tried to print using the split view report, and I'm trying to create a report for all of my flights (about 700). I've viewed my logbook in report form before but never printed it, and it would create the entire report for all of my flights.

However, I tried this morning and it will only create 1 page for the first year I entered a flight and it won't populate any data, just the year.

I've tried this on all the separate report functions, even the customizable one, and they all produce the same result.

I tried closing my logbook and reopening it. I reinstalled the program, and then went as far as backing up my logbook, uninstalling the whole program, deleting my .lbk file, and then installing the program from scratch. It still won't create a report.

It's a head scratcher. Any ideas? This is getting to be frustrating.

I attached a screenshot of what the report that is being created looks like. I can't get it to go past that using any type of report.

View attachment logbook example.doc
 
Joined
Jan 12, 2013
Messages
7
Hello Ryan,

Click Reports / Flight Log / Split-Reports / Commander or Full Size series - when the date filter shows, click ALL DATA on the lower left.
That's the problem, I DO click ALL DATA, and it just gives the 2004 page that I attached. If I select the dates of 1 Jan 13 to 12 Jan 13, it gives the same output, the year is just changed from 2004 to 2013. I have a few flights this year so there is data to populate the report.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
The report you're trying to run is different and doesn't seem to render properly, may be a resources issue on your machine, not sure. Try the report I outlined above and see if it works for you. If you have a different computer to try, see if that makes any difference.
 
Joined
Jan 12, 2013
Messages
7
I've tried running every report that Logbook Pro offers. The only one I can get an output on is the Logbook Pro Standard Flight Log and I don't particularly like that one.

Where is the program working in the registry? I've completed uninstalled the program, the manually deleted the files that have been left over in the system folder for Logbook Pro as well as the Logbook Pro files in the My Documents folder. Then I restarted the computer to purge anything left in the registry and it still doesn't work. So the program itself would appear to be latching onto something (or simply not releasing the process after uninstall) and is corrupting the program.

I don't have a different computer to try it on.

Is there a way to get an older version to try and see if it's the current version that is causing this problem? Like I said, I have viewed my entire logbook in a previous report, I just never printed it out because I didn't have a binder to put it in.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
This issue is most likely a driver issue in Windows related to the database system external to Logbook Pro. Uninstalling and Reinstalling Logbook Pro itself won't resolve this. A reinstall of Windows (or upgrade to Windows 8) would likely resolve this as something has become corrupt. Please fill out a support ticket at NC Software - and we'll see if we can assist you further.
 
Joined
Jan 12, 2013
Messages
7
Thanks for the guidance Neal. Turns out that Windows was corrupted. I had to do a repair/install of windows, now it's working swimmingly. Thanks for the quick responses.
 
Top