problem importing from LBP v1.5x

cggatlin

New member
Joined
Sep 3, 2003
Messages
2
heya
I am helping my brother transfer files from an old PC to a new one. He is also upgrading from LogbookPro v1.5 to v 1.9.4. Unfortunately, it would seem that the new version of LBP cannot adequately import the old files - it is completely corrupted after importing.

-I made a backup of his database in version 1.5
-I restored this backup into version 1.9.4
-it only offers to upgrade the database and put in new features
-when we open the new database file, nothing is where it should be
...............one thing, he has some custom fields that he has defined. Will these extra fields screw up the import?

so........
I tried to do an import of a CSV file, which worked better but still with a few problems.
One thing I do not understand. You have this great export feature in v1.5, and there seems to be no export feature in v1.9.4? The help files in v1.9.4 even reference an export feature.
What gives? Why is this no longer offered as a feature? I really needed this feature to get even halfway there going from v1.5 to v1.9.4 - what do I do for the future?

-upon doing an import of the CSV file, most everything could be matched up, and successfully imported, save for one thing....the approaches.

in my text file, I have several fields of approaches, but I am not offered the appropriate fields to match them up to on an import into v1.9.4

do I need to set up something like a template?

If the database import is not working and the restore from backup feature is not working, what do I do.

Thanks in advance
cggatlin
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
cggatlin,

All the features of 1.5 are certainly in 1.9.4, they may be in different menu or toolbar locations. However, you should see the File...Export options.

There can sometimes be a problem going from a very old version, such as 1.5 (3-4 years old) to the current version. If you e-mail me the backup file of version 1.5 (or winzip compressed .LBK file) I will do the update and return a 1.9.4 backup file to you.

 

cggatlin

New member
Joined
Sep 3, 2003
Messages
2
I will go back and look for file, export, but I swear it was not there. I even looked for it contained within the 'save-as' feature as MS Excel now does. Not a problem, though. Maybe I can do a snap-shot with the drop-down menu?

I will be happy to email you the backup file from 1.5. MY brother loves this program, and he is always a bit nervous about upgrading. I think this is the cause of the delay for upgrading through the years. I know how hard it is as a developer to cover all the case-scenarios that one needs in place so ALL previous versions can be imported. The closest I got to doing a full import was to first do a restore of the original database, which then included the custom fields my brother specified in the table(s). After the restore and auto-upgrade of features to the database, everything was there, but the data was crunched.

I then decided to do an export from the old v1.5 program to a CSV (comma-delimited text / database file, if anybody was wonderin'). I then imported this into v1.9.4 and found most fields to match up to except for approaches. All the hours were correct after this, but I was still left with no place to put in the approach data. I guess you upgraded the database structure, so approaches must be a subset of some other field in the main dataset?

Thanks again for the quick response. I appreciate the candidness also.
 
Top