Bug in PPC 1.10.16 ???

Jay Chandler

Member
Joined
Mar 28, 2005
Messages
18
Location
UK
Not sure if anyone has seen this before but I think it may be a bug:
Software is PPC 1.10.16, Logbook Pro 1.10.40, Windows Vista.

Everything was working fine until I recently tried to sync data from the PPC that included entries going over the month end, ie I had entries spanning 24th May to 1st June.

The sync took place ok, but on clicking finish after the sync completed I was presented with a completely empty database in Logbook Pro. Somewhat alarming as I have nearly 8000 hrs of data!!! I closed Logbook Pro - which then updated the PPC with correct totals for all the reports on the PPC, but deleted all the synched data from the PPC.

Opened Logbook Pro again - immediate message saying data file was corrupt and I should restore a backup. On selecting OK, Logbook Pro closed immediately with no opportunity to restore a backup. This happened every time I tried to open Logbook pro. Fortunately I keep a synched copy of the MyLogbook.lbk file, and synched copies of weekly backups on another computer, so I copied that file back, overwriting the corrupted data file and Logbook Pro opened normally with all my old data.

I have since found that If I deleted either all the entries from May from the PPC, or deleted the single entry from June, then the sync takes place without a problem.

It appears therefore that you need to make sure you don't enter data spanning one month to the next into the PPC and then try a sync.

Hope this info might help save someone else having a minor heart attack!!

Cheers
Jay
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,572
Location
VA
Hello Jay,

It shouldn't matter how much data is on the PPC or spanning months, I'm not sure what problem you encountered. Good job on keeping backups. It may have simply been a corrupt data file and by going back to your backup copy you fixed the issue. I would feel better though if we rebuilt your data file so it's moved to a new one so you don't have this problem again. Please submit a support ticket and we'll give you the steps to force a rebuild.
 

Jay Chandler

Member
Joined
Mar 28, 2005
Messages
18
Location
UK
Thanks for the quick reply as ever Neal.
I have replicated the problem 3 times by re entering data into the PPC, but I was of course always starting with the same backup so the error may have been in that file I guess. Having entered the last week of May manually, everything is working fine again now and I am doing daily rather than weekly syncs for a while.

Support ticket is on the way for instructions on rebuilding my data file.
Thanks
Jay
 
Top