Can't Install

Newps

Member
Joined
May 15, 2005
Messages
18
I have the latest version of LBP, 1.9.8.5. When I try to install it to my Dell Axim X50v it seems to install OK except for the fact that the wizard gives an error message on step 2, setting up active sync. It says that there was an error and to uninstall the program and start over. I have not purchased a license as I have had LBP for several years and it has never succesfully installed on my pocket PC's. It works on my Kyocera 7135 phone but never on the Dell. I read an earlier message about uninstalling and then going into the program files and deleting certain things. I did that and tried again, no luck. Before this version of LBP I would follow the instructions and what always failed was setting up the Pocket Access. I would type in the destination and I would copy and paste. Didn't matter. Always the end result was the error message that there was no such database or words to that effect. It is very disappointing, I have had a PPC for several years now and never have a hard time installing software, except for this one. I keep seeing the admonishment to 'follow the instructions exactly.' This to me is a red flag. I should only have to click 'OK' or 'install' as I follow along the instructions. If I have to be told to be careful that's just bad software. I really like the PC and Palm versions, the PPC version leaves a lot to be desired.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hi Scott,

The reason it is stressed to "follow the uninstall directions exactly/completely" is due to a history of people not removing the software completely from the PPC. Unfortunately, the install/uninstall technology for the PPC's are not as robust as your PC. The reason it is stressed to follow every step in the uninstall directions is to compensate for a known bug with ActiveSync where if the data file exists on the PPC already it will not overwrite it, which ActiveSync *is* supposed to do, but has a bug where it will error out instead. This has been an issue since ActiveSync 3.7.0 was released. Install is now automated, as you suggest, however, when there are compounding issues, we have to work with our computers, PDA's, etc. to overcome other influences/shortfalls/bugs. The Palm OS is much more mature and reliable in my opinion than Microft's mobile OS. That's not surprising as it's not Microsoft's focus, whereas the Palm OS is PalmOne's focus, which is why it is superior in my opinion.

I see no reason why Logbook Pro's Pocket PC Companion will not work on the supported OS's as listed on the Logbook Pro Requirements page.

Be sure you are installing only to the default location (main memory) and not a SD/external storage card. All installation defaults should remain as the default, unchanged. With a clean PPC (no \Program Files\Logbook Pro folder existent) you should have no problems whatsoever.

Please provide any specifics as to the exact error message, etc. and I'll continue to assist.

 

Newps

Member
Joined
May 15, 2005
Messages
18
I went thru all the previous steps. By the way when I go to program files after uninstalling the software there is nothing left, so it seems activesync is doing its job. Same error message as before. Step one completes fine, the installing into the PPC. I normally install all my software onto the SD card. This is the third time today I have tried the install. First to the SD card, then to the BIS. (Neither one of these is the default install location.) The third time I let it install to the default location, main memory. The hangup is the same as before, step 2. The error message reads...'An error occured transferring the data. Completely remove software from pocket PC (refer to documentation) then reinstall. In all cases when I try and run the program it just turns the PPC to mush, speed wise. You have to do a soft reset to fix it. Pocket Access does not get its box checked by step 2. When I start over and check Pocket Access first and then install I get the same error message. I do nothing else with setting up Pocket Access, not like the last version where it wanted you to go in and uncheck most of the boxes, etc. I figure that's what the wizard is for.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Scott,

You cannot install to a SD card, you must install and use Logbook Pro only from main memory.

After uninstalling Logbook Pro from the remove programs area on the PPC, go to the File Explorer, then \My Device\Program Files and delete the 'Logbook Pro' folder. After this directory is confirmed not to exist (while the device is removed from the cradle) delete your ActiveSync partnership. Re-cradle, recreate the partnership, run the PDA Wizard. After doing so, go into ActiveSync's options and ensure Pocket Access is checked.

If the instructions are followed explicitly and completely, there will be no problems. SD cards are not supported. The error you describe is that of ActiveSync and a known bug where it will not overwrite data that already exists on the PPC. This is why the 'Logbook Pro' folder MUST be manually deleted when reinstalling to the PPC.

 

Newps

Member
Joined
May 15, 2005
Messages
18
Did all that, still didn't work. Thanks for trying. Same error message at the same step 2. Pocket Access doesn't get checked by the wizard. I check the box, let activesync resync and then start the program. Nothing. PPC slows to mush and I must do a soft reset. I'll check back in 6 months and maybe the install will be fixed. This is, by far, the most difficult program I have ever run into with a PPC. Everything else will install and run. In the end I may not like it but they always run. You have to get me to that point with just a couple of OK clicks from me.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Pocket Access does not get checked automatically, that is why it is in the documentation to ensure it gets checked. I'm not sure why it's running slow on your device, there is something definitely wrong with your configuration. We see great performance on our HP iPaq's.

The problem may be your data needs to be purged. On the PPC main switchboard screen, click the Tools menu then the option to purge the data. Please create a backup of your PC logbook data file (File..Archive..Backup) and e-mail it to support@nc-software.com and I'll make sure the merge queue isn't saturated due to the issues you've been experiencing.

 

Newps

Member
Joined
May 15, 2005
Messages
18
The program doesn't actually run on the PPC. Never has. When you tap on the LBP icon on the programs screen the PPC slows to a crawl and you can't do anything with it without doing a soft reset first. This is the second Dell I've had a problem with. The first was the X5. Always have the same problem. I believe it's with Pocket Access. With the older version of LBP there would always be an error message that the database wasn't where it was supposed to be. I suspect the problem is the same now with the wizard it just doesn't tell me that. It just says the install fails, uninstall and try again. I will email my data file.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Scott,

Your data file looks 100% perfect, no problems or concerns noted. I am going to order a Dell Axim and see what's going on with the Dell devices. I typically test on several HP models but Dell is and has always been the problem child, I need to see why.

Do you run any applications requiring the .NET Compact Framework that you know of? I'm wondering if Dell installs this by default and if it is a conflict with Pocket Access or Logbook Pro running on the device. If you want to try...see if the .NET Compact Framework (CF) is listed in the Remove Programs area and uninstall it. See if that resolves the issue.

If not, please e-mail support@nc-software.com your phone number and I'll arrange a call to step through this and see if we can pin this down.

 

Warcaw

New member
Joined
May 19, 2005
Messages
4
Hope you find a solution. I bought logbook pro and pocket companion yesturday and I can't get it to sync with my dell axim either. I have done all the steps in the help files and on the forum at least 15 times and still can't get it to work. Here's hoping you find a solution to the problem.

Chris
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hi Chris,

There are no known issues. Just because one person is having a problem with the software running on an Axim does not mean anything, there could be various reasons on one device for it not working properly, just like running Windows and something could be foobar'd on a particular machine.

To get Logbook Pro to talk to the PPC requires that you enter your PPC registration code on both the PC (Under PDA Companions\Pocket PC Companion menu area) and also on the device itself. Once both "ends" are registered, they can freely talk to each other. Make sure "Pocket Access" is checked in the Options area of ActiveSync 3.8 per the documentation.

If you'd like to start over fresh, follow the uninstall directions completely (every step) to purge Logbook Pro from your PPC. Then re-run the PDA Wizard and ensure you have Pocket Access checked, then perform a sync. Make a test flight log entry on the PPC then do an ActiveSync and see if the flight entry appears on your PC logbook.

 

Warcaw

New member
Joined
May 19, 2005
Messages
4
Neal,

I have followed the directions over and over again. I have put in my registration code in through the PDA wizard. My next question is when you say put the registration codeon the device itself, how do you do that? When I try and start the programon the PDA it says the data file is missing and to run active syncin the PDA Wizard.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Chris,

Please e-mail me at support@nc-software.com and include your phone number and what is a good time to call on Friday. I'll walk you through the install process. The data file is not being sent to the PPC which is causing the error message. Please ensure you are installing to main memory and NOT an external storage card. All defaults must be left as is when installing to the PPC.

 

Warcaw

New member
Joined
May 19, 2005
Messages
4
Neal,


I have to go back and fly the line for the next couple of days, and will be out of touch with my computer. I will try working with it a little more. If I can't get it to work i'll send you an email early next week. Thanks for all the help.





Chris
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

I received a Dell Axim 50v for testing from another developer and Logbook Pro installed and ran perfectly, no problems noted. The Dell Axim 50v was clean, out of the box, ActiveSync was version 3.8 as downloaded from Microsoft's web site and not installed from any Dell CD's packaged with the Axim 50v. Nothing from Dell was installed for that matter, it was simply the stock Axim and ActiveSync.

Scott, as far as the error installing, if on your PC you go to Start...Control Panel...Administrative Tools...ODBC 32 (Data Sources) do you see a User DSN or System DSN entry named 'NCSoftware'? I'm curious if Logbook Pro was able to write that to your PC or not, although the User DSN is not required in 1.9.8.5 as Logbook Pro can communicate in an alternative backup mode automatically if it is missing. I'm curious if that's the error message you are receiving.

This issue sounds similar to one other customer where he doesn't have the database drivers on his system which is still being researched as to why Windows XP is missing this information in his particular setup.

To summarize, there are no problems noted with the Dell Axim PPC, it is an impressive device and runs Logbook Pro nicely.

 

Newps

Member
Joined
May 15, 2005
Messages
18
ODBC32 is not listed. Data Sources(ODBC) is. Double clicking that I get ODBC Data Source Administrator. NC Software is there under User DSN, not listed under System DSN. Like I said I have given up. I have a second X50, this one is the mid, not the V. I just got this PPC a few weeks ago and the only other program I have installed is NavGPS Pro and configured it for a bluetooth GPS. I may try it on this PPC but I don't think it is the PPC, I have already tried it on two.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Scott,

I too believe it is not the PPC and is most likely something on your PC that is missing. I don't know what that is at this time. Logbook Pro (or its data) is never getting to your PPC, regardless of the device, and I'm not sure why. Do you have another computer to try? I'm pretty sure if you connected your 50v to another computer with Logbook Pro it would work fine. If you have Microsoft Office with Access, try installing that on the computer with the issues and see if it clears it up. The Access drivers are probably what's missing. If you go into the Data Sources (ODBC) area, then User DSN page, click the ADD (or New) to create a new User DSN, is 'Microsoft Access (*.mdb)' listed?

 

Warcaw

New member
Joined
May 19, 2005
Messages
4
Hey Neal,


I fixed the problem! The problem was the access driver missing, due to aregistry issue. I found a work through on Microsoft about the problem and everything is working great! Thanks for all your help. Here is a link to the work through so others having the same problem can fix it. http://support.microsoft.com/default.aspx?scid=kb;en-us;324520I used Method 2: Reset the Registry Subkeys by Using Mdac.inf to fix the problem.





Thanks again,


Chris
 

Trevor Baker

New member
Joined
May 29, 2005
Messages
1
I had the same problem when I tried to install LBP on my iPAQ in the File Store. When I installed the software in the Default Directory, the synchronisation set up worked fine.
 
Top