Flights out of order after PDA Sync...

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,573
Location
VA
An issue has been reported that I'd like to make the PDA users aware of until the next update is available:

It was brought to my attention that flights entered on the same day are being Sync'd out of order to the PC. Here is what's happening:

Flights when entered in Logbook Pro are time-stamped then sorted first by the Date of the flight, then by the entry time. So if you have multiple flights on the same day, they will be viewed in the order of entry.

The problem is when you go back and edit a flight. The "bug" is that this time stamp is updating on a EDIT operation when it shouldn't, which is throwing flights out of order that have the same date.

There is no update planned at this time for 1.9.x of Logbook Pro therefore I want to make you all aware of this issue until the next update releases, if there is another 1.x update.

I have made the beta builds of the PDA software available (v1.2.2) if you'd like to install. These require 1.2.1 to be installed first. Data will NOT be overwritten on these installs.

For the Palm Companion, download from the following URL, then extract the .zip file and double-click the .PRC to trigger install on the next HotSync:

<removed outdated link>

For the Pocket PC Companion, download from the following URL, then double-click the .exe file AFTER your PDA is connected via ActiveSync and ready to have the software installed. Data will NOT be overwritten in this install and 1.2.1 is required on the PDA prior to installing this build:

<removed outdated link>

Report any issues to support@nc-software.com and thanks to those that reported this "feature." /forums/emoticons/smile.gif





 

geira

Member
Joined
Nov 15, 2001
Messages
18
Hello Neal


Appears that this problem is still occuring with the latest version.


Please see attached picture.



Now that the entries are out of order is there an easy way of getting them back in order. I've tried refreshing, sorting, cut & paste etc.
Right now I can't think of any other way than entering all the flights for that day all over.

Thanks, Geir
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,573
Location
VA
Geir,

Please uninstall then reinstall the PDA companion as I am curious if you have an older build or if you tried to install the latest it didn't overwrite your prior version. This issue should have been resolved in the 1.9.6 build for the PDA Companions. To correct the issue you would have to delete the flights for that given day and re-enter them in Logbook Pro in the proper flight order.

I have logged this issue for review in the next revision should it in fact still be an issue.

 

geira

Member
Joined
Nov 15, 2001
Messages
18
Not a problem with a prior version, it's a new PDA bought this summer..
I was thinking maybe it's a problem with the regional settings again, I'll change my settings on both the desktop and PDA and try it out.
 

geira

Member
Joined
Nov 15, 2001
Messages
18
Affirm, just switching settings to US regional settings now. I'll log that day again on the PDA and go back and edit one entry.

Geir
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,573
Location
VA
Great, yeah, make bogus entries too and run it through any testing you can, you can always delete them. See if you can duplicate the issue with US settings. Then if not, try your original setting and see if that makes a difference, i.e. breaks it.

 

geira

Member
Joined
Nov 15, 2001
Messages
18
Sorry Neal.
Same problem with US settings, still out of order after editing previous entries.


And I also encountered some odd behaviour;
When I enter flights on my PDA I enter them "opposite direction" when it comes to the different "entry-pages" (general, approaches, expenses, remarks and custom text). Meaning the first flight I enter i start with "general" and I end up with entering custom text (a custom text field called Commander), after I've entered the text field "commander" I save the entry by pressing the disc-icon and then the paper-icon to clean out the previous entries. So the second flight I enter I start with "Commander" and then end up with "General".

Did this make sense?
The problem is that some times the onlypage that has been "cleaned" is the custom text . Every otherpage is left from the previous entry.
And every time I save & clean on the custom text page the aircraft type jumps to the first aircraft (alphabetical order), this does not happen if you save & clean on the general page.

Complicated to explain, but I hope it makes sense, Geir

BTW. after swithing regional settings I was unable to merge data from the PDA (Activesync was running properly). So I had to remove & re-install LBPro. Now it works again
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,573
Location
VA
Geir,

Can you please uninstall from the PDA, ensure you have 1.9.6.5 installed on the PC, then reinstall to the PDA and retry? I have a feeling you have an older version on your PDA.

If using the Pocket PC Companion, please refer to this link:

http://www.logbookpro.com/Forums/?f=10&m=3923

 

geira

Member
Joined
Nov 15, 2001
Messages
18
Well, the PDA was factory new in August so that shouldn't be possible (I've always updated LBPro with the latest version by removing & re-installing shortly after you've released new versions).
I did reinstall according to instructions in http://www.logbookpro.com/Forums/?f=10&m=3923
I also reinstalled LBPro on my desktop.

Desktop computer: Win XP Pro SP1 (Norwegian)
Regional settings: Norwegian (bokmal)
ActiveSync Version 3.7.1 (Build 4034)

PDA: Dell Axim X30H
Windows Mobile 2003 Second Edition V. 4.21.1088
Regional settings: Norwegian (bokmal)

Hope this helps, Geir
 

geira

Member
Joined
Nov 15, 2001
Messages
18
If you think it will help I can remove my logfile from the Logbook Pro directory and delete that directory from my desktop and then do another re-install.
 

geira

Member
Joined
Nov 15, 2001
Messages
18
Ok, in that case I can confirm that I have 1.9.6.5 showing on the desktop and 1.9.6 showing on the PDA.

Geir
 
Top