How do I turn off N number & route autofill?

Winglet

New member
Joined
May 21, 2005
Messages
2
When I import data from the Airline Pilots Daily Aviation logbook it imports everything as one basic type of aircraft without any model details. IE: 757
I fly the 75 and 76 and track the flying time in each different model. IE: 75-200&300, 76-200&400.

The problem I have is that when I change the model number in logbook pro the imported N# changes to the last N# flown (from a previous entry). How do I turn this off so that I can just go through and change the aircraft make and model without having to deal with remembering the N# before it changes and then re-entering it?

Also when I enter my GA flying the last route I flew in that aircraft autofills. Its not a major hassle as I have to enter something there anyhow but can I turn that off as well?
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

It is 'by design' that whenever the A/C Type changes Logbook Pro will repopulate the N-Number column and drop down unless the N-Number is a match. Logbook Pro tries to help you keep N-Numbers paired with the corresponding Types and this cannot be disabled. I suggest clicking in the N-Number field prior to changing the type, press CTRL+C (copy to clipboard), change the A/C Type, then CTRL+V (paste) in the N-Number column and all should be fine.

There is no provision to disable 'recent entry recall' at this time.

 

Winglet

New member
Joined
May 21, 2005
Messages
2
Mmmmmmmkay.


Please add that to the wish list then. It sure would be nice for those of us who fly many differentN#'s of the samemodel and transfer data fromthe Airl.PilotsDaily PDA log.
 

gonzo

Active member
Joined
May 31, 2005
Messages
27
I would also like to be able to turn it off. Is there at least a way to clear the history of the route bar?

The problem occurs when you fly trips with a lot of legs, enough to overfill the field. When you start to manually enter in a leg, it auto fills a route that starts with the a similar letter(s). If the route you're trying to enter is different, but from the same airport, you cant see what you're typing.

Also, if you've flown a route that happens to be part of a longer route in your history. When you type in your shorter route and hit the tab key, it autofills the rest of the longer route. The only way to get around this is to type your route and hit the space key, which is counter-intuitive to the tab key to advance usage. This problem is compounded when you are unable to see what you're typing due to the previous problem.

One route at a time and this is not a big deal, but when you're trying to enter in a lot of data, it becomes a hassle. All this would be not be an issue if you could turn it off or clear the history.

thanks...
 

gonzo

Active member
Joined
May 31, 2005
Messages
27
ok.. found a working solution for my needs.

if you've flown long routes in the past, the auto-complete makes it so you cant see what you're typing if you're trying to manually enter in a route that starts with similar letters as it tries to 'assist' you.

what i've found that solves the issue is to press F4 when you're at the route window. for the rest of your data entering session, it will only try to auto-complete from the most recent data entry, and not the longest one it can find. it also lets you just use the down arrow to cycle through your most recent routes entered.

once you close the program, you have to hit F4 at that window again to get it working.
 
Top