iCal calendar export no longer working


Well-known member
Feb 4, 2007
I used to get duplicate entries. Now I am not getting anything at all. Tried deleting events, turning off calendars, turning back on. Nothing seems to work.
I used to get duplicate entries. Now I am not getting anything at all. Tried deleting events, turning off calendars, turning back on. Nothing seems to work.

Try turning the calendar setting completely off then power cycling the device. I'm using the current App Store build on my iPad and the latest Beta on my iPhone and have had no problems at all.
Turning calendar sync off and back on won't resync your events to the calendar. Once they are removed, you have to make an edit on an entry and resave it in order to get it to be added to your calendar.

With your calendar sync turned on, go make a temporary change in one of your entries such as changing the OOOI times by a minute or so and save the leg.

We have some improvements for the calendar sync system in the next app store update.
Hey guys,
Haven't written in a while. On reserve now with new carrier.
My google calendar, after syncing APDL, was only showing the legs for about 18-20 hours ahead of the current time. I followed Andy's steps listed above and the problem fixed itself. I just wanted to share my little issue.
I have a parallel issue. I had a trip in APDL on 10Jul. I was able to swap it for a trip on the same exact four days so I imported the new trip. It correctly overrode the first trip in the app but it did not remove the associated calendar entries.
Hey guys,

Has there been a fix to this? I'm unable to sync my apdl to my iCal. I have flight segments selected but it does not add them to my iCal.

I've tried to delete all events, change times and re sync. I've power cycled etc. No luck.

Also, when it did work, it defaulted as setting a notification 30 minutes prior to event even though my iCal phone default was no notification. Is there a way to have apdl add it to iCal without a deflated phone calendar notification?
I'm not experiencing this issue. One other thing you could try is choosing a different calendar, let it sync, and change it back to the original one.

We have had some issues with calendars but I'm not aware of any current issues with them. What service are you using for calendar? (Gmail, iCloud, etc)
Okay, I got it working again by selecting a different calendar and selecting all options. I then left all options selected and went back to my gmail calendar and it worked. However, it still shows an alert 30 minutes prior to the event. Is there a way for the settings to have no alert without going into each flight on the phones calendar and manually changing it? The reason I ask is that I have a shared calendar and my family hates getting alerts 5 times a day for each flight. They would rather look on their own than be alerted prior to each flight.

I I have my phones calendar set so that all new entries default to no alert, however, each apdl entry adds a 30 minute prior alert.
I have seen that before with a gmail calendar. go to the calendar settings on a PC browser and make sure the default reminder is set to off there. That will override the phone settings.