Logged More RTG problems - no credit!

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
I thought I'd figured out how to do an RTG. I was able to get it to work by faking the flight number (to prevent autofill of times) and faking the scheduled times so that scheduled and actual were the same (to prevent over crediting due to block or better.). This DID work last time I had an RTG. Today our had an RTG and for some reason it is not crediting. Here are screenshots:





Why isn't it showing credit for the RTG? I had a very similar trip last month which IS showing credit. Here is that one (2 screenshots because it was longer than the iphone screen)





Both rtg legs are built exactly they same way. This is not the first time that the software does weird, inconsistent behavior. There seems to be no rhyme or reason why something works one day and then you do the exact thing the next day and it has different results.
 
Last edited by a moderator:

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
Just discovered that the rtg is somehow linked to the next leg, the second attempt. So when I changed that second leg from cancelled to block I got credit for both. But when I set it back to cancelled I got zero for the RTG. That needs to be fixed.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
Also notice that on the leg view there is no place to enter ACTUAL times, only scheduled. Did this change with 7.0.6?. The rtg that I built before the sw update still shows the actual times, and credits correctly, but does not show actual times in the leg view.

Can we get this bug logged please?
 

Steve Hayne

Support Engineer
Staff member
Joined
Apr 10, 2009
Messages
403
Location
Ohio
Ok, I just double checked my RTG the other day and the app is calculating correctly. I flew one leg and on the second we RTG and then eventually canceled. My credit for the day is showing correct. Make sure you have "Apply to Pay" turned on for the Canceled payroll category and recheck.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
Check the screenshot above. It shows clearly that APPLY TO PAY is selected.

YES, there is no place for actual times:



This worked before 7.0.6. Now it is messed up pretty badly.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
You probably entered the RTG before updating to 7.0.6. My rtg before 7.0.6 worked also, although I had to manipulate it a bit (see above about the need to change the flight number and scheduled times) it still calculates credit correctly.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
But even the pre 7.0.6 RTG does not show actual in the leg view.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
However in the trip view it still has the actual times and credit.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
So I figured the only way to correct the credit was to change RTG back to block. Look at the block total for the trip. It isn't even correct!

 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
I am extremely disappointed. There are so many bugs and data reliability issues that this software is almost unusable.
 

pcohen

Well-known member
Joined
Feb 4, 2007
Messages
280
Last week it seemed as if you guys were working hard trying to fix things. Now I am not so sure.
 

Steve Hayne

Support Engineer
Staff member
Joined
Apr 10, 2009
Messages
403
Location
Ohio
Check the screenshot above. It shows clearly that APPLY TO PAY is selected.

YES, there is no place for actual times:



This worked before 7.0.6. Now it is messed up pretty badly.
The Return to Gate not calculating pay correctly is a bug, I logged it - see my previous post. It does calc correctly in the instance where you RTG and then cancel and the canceled leg is marked apply to pay. Where it's not working properly is when you have a single leg marked RTG and no follow-on canceled leg with "Apply to Pay" turned on.
 
Last edited:

Steve Hayne

Support Engineer
Staff member
Joined
Apr 10, 2009
Messages
403
Location
Ohio
So I figured the only way to correct the credit was to change RTG back to block. Look at the block total for the trip. It isn't even correct!

Did you use the "Set all legs" for those canceled flights? Try setting them individually and see if that makes a difference. Also try opening the first leg, tap the payroll, reselect Block and save again. There was an issue with the "Set all Legs" feature that we are resolving.
 
Top