.NET Compact Framework v2 required for PPC 1.10

Status
Not open for further replies.

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
The new version of the Logbook Pro Pocket PC Companion uses the new Microsoft .NET Compact Framework version 2 available from Microsoft. Click here to download. We also recommend our APDL users to also install this newer runtime engine.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
In an effort to make the installation of the .NET Compact Framework easier, I have isolated the typical file you will need to install on your device. If you do not have the .NET Compact Framework v2 as of yet, instead of download the 24.5 MB installer from Microsoft, follow the steps below and you'll only need to download 2 MB!!!

Click the link below based on the device OS you are using:
  1. After downloading the above zip file, extract the zip file and you will find a single .CAB file. Right-click this file in Windows Explorer and choose COPY or press CTRL+C to copy to the Windows Clipboard.
  2. In Windows Explorer, while your PPC is cradled and connected via ActiveSync, click Mobile Device
  3. On the right side of Windows Explorer, Double-click the top item, if Windows Mobile 5 it is "My Windows Mobile Based Device"
  4. Double-Click TEMP
  5. Right-click and choose PASTE which will transfer the CAB file to your device. Click Yes/OK to the dialog that appears about some conversion message.
  6. Close Windows Explorer
  7. On your Pocket PC, go to the Programs area, then start the File Explorer. Go to the top level folder "My Device" (at the top) then click the TEMP folder
  8. You'll see the CAB file, tap it once to initiate the install of the .NET Compact Framework v2. You most likely will have to reset the device when completed (it will tell you to) and also reconnect via ActiveSync (uncradle/recradle)
This "should" install the .NET Compact Framework v2 without having to download the full 24.5 MB installer, which contains the software for every device known to mankind! If the above steps fail, well, go back to the Microsoft installation option and give that a shot.

*Note: Our Software CD-ROM's will contain both the .NET Compact Framework v1 and v2 installations for those that need it. APDL uses v1 and Logbook Pro uses v2. v2 should work for both APDL and Logbook Pro.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
With the 1.10.14 release and later, you must also have the .NET Framework 1.1 installed on your PC. You may already have this installed as it is a part of Windows Update. To check whether or not you have it installed, please see this article.

*Note: There is also a Microsoft .NET Framework 2.0 for your PC. As it seems this is a later version, it is actually a completely separate installation. Logbook Pro requires that you specifically install version 1.1 of the .NET Framework. You can also install 2.0 as our later applications will use this, both can be installed on the same PC, they are again separate runtime engines altogether.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Update as of July 11, 2006

A new installer is now available which includes the .NET Framework 2.0 SP1 with the installation of Logbook Pro Pocket PC Companion. This will simplify the overall process and ease the confusion.

Click here to download the Logbook Pro Pocket PC Companion software WITH the Microsoft .NET Compact Framework 2.0 SP1.

On your PC, you must have the Microsoft .NET Framework 1.1 (this is different from the .NET COMPACT Framework.

If you have any questions, please submit a support ticket and we'll gladly assist you promptly.
 
Status
Not open for further replies.
Top