New ActiveSync is broke

wilsonm

Member
Joined
Apr 5, 2003
Messages
7
Hi all,

I have been using my Pocket PC companion for a few months now. I decided to format my computer and reinstall all the latest versions of all my softwares right the first time. I also happened to install the new active sync 3.7.1.

But now I can't use the pocket PC companion anymore. I also reset the memory of my pocket PC (iPAQ 3955) and reinstalled evreything from scratch. I followed all directions exactlyas stated in the help file in order and perfectly. I have done it a few months ago when I first purchased it and it worked perfectly. The access database is selected, the file location is correct (copied and pasted) and all the correct boxes were clicked - and no other.

The only thing that is now different is the activesync 3.7.1. I tried uninstalling it and re-installing it multiple times, unchecking and re-checking the pocked access selections, following the entire help file procedures again and again, and nothing.

I have even downloaded the new appforge booster (4.0), uninstalled the old one (3.5), and installed the new one and I keep getting the same message. So whats going on here?

"The database required for the Pocket PC Companion was not found. Please rerun the configuration as outlined in the Logbook Pro help file."

When I explored the file location in the Pocked Device, I have noticed that the file is not there at all (using the path given in the help file and during installation).

Any help!?
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

This error is typically due to not specifying the path correctly when configuring ActiveSync. Be sure to enter it exactly as shown below:

\Program Files\Logbook Pro\Logbook.cdb

If necessary, uninstall and reinstall ActiveSync (or delete the partnership), hard reset (cycle power) on the PDA.

HTH

 

wilsonm

Member
Joined
Apr 5, 2003
Messages
7
As I mentioned before, I have setup the companion exactly as instructed by help file.

exact path: \Program Files\Logbook Pro\Logbook.cdb

All the correct options were selected, the correct path pasted, access database selected, I haveuninstalled and reinstalled ActiveSync,deleted the partnership, hard reset (cycled power), and reset PDA system (wiped out memory). I have uninstalled the old Booster software and installed the new version 4.0.

I have successfully installed it and used it multiple times in past year. This has never been an issue before.

Any other ideas?
 

maxbraking

Member
Joined
Nov 12, 2003
Messages
5
Just a note:

This is exactly the same problem as in the post 'iPac 1940 and no Database transfer'. I have re-installed everything and tried around 10 times but still to no avail. I get the same message; 'The database required for the Pocket PC Companion was not found. Please rerun the configuration as outlined in the Logbook Pro help file.'

With Activesync the 'Pocket Access' checkbox does NOT stay checked when the iPac is attached and then detached.

Regards
 

donaldbm

Active member
Joined
Oct 3, 2002
Messages
43
Wilson,
The common thread between you and me is that I also reformatted and upgraded my PC. I had been successfully using active sync with W98 but the problems started after I had upgraded to WXP. As I mentioned in another post, I have managed to get it work once but have been unable to duplicate that success.
???
 

wilsonm

Member
Joined
Apr 5, 2003
Messages
7
In response to "maxbraking," pocket access box seem to be checked when connected and also disconnected. Does not seem to be a problem on my case.

As Neil has suggested, I was looking for the older Async 3.7.0 but noticed that Microsoft has removed it from their site. They only allow the download of the 3.7.1 or of 3.5 for compatability now. Can't find the 3.7.

Like Donald, I'm also not a fan of stepping backwards with my software (to 3.5) due to other compatability issues. So I am going to go ahead and wait to see if the forecasted LBP 1.9.5 has a correction to this issue, or if Microsoft may put out a new version (3.7.2) as they may have just created a new bug.

I will step back to ASync 3.5 as a last resort and against my will if all else fails. I am now confident that this is the issue, asASync was the first item to be installed after I loaded XP 6 months ago and still the first item I installed this time. The only difference from now and than is the ASync version.

Until I get to play with LBP 1.9.5 or a newer ASync (unlikely) I will have to keep bringing my paper logbook home on my days off ;-(

Meanwhile, happy flying guys!!!
 

pacemaker323

New member
Joined
Nov 14, 2003
Messages
2
I've gone through the installation steps EXACTLY several times now, and I keep getting the same message,
"The database required for the Pocket PC Companion was not found. Please rerun the configuration as outlined in the Logbook Pro help file." I have a Dell Axim 5 and Active Sync 3.7.1. I told want to be told to regress to older software, but I have even tried to find a downloadable version of the older Active Sync but could only see 3.7.1. I want a more acceptable solution than looking for outdated software. Any ideas?
 

wilsonm

Member
Joined
Apr 5, 2003
Messages
7
Hi Pacemaker323,

Logbookpro Companion and Activesync 3.7.1 are definetely incompatible to each other. I had trouble finding the 3.7 version, but got it from (one long line):
http://www.microsoft.com/downloads/details.aspx?FamilyID=67e9e87c-ca96-48b4-b5d4-f3e047ca5108&DisplayLang=en

By regressing to this previous version, all problems get solved - just make sure to set it up the database correctly afterwards. The previous version (3.7) has solved mine, along with 'maxbraking' and others... There isn't much difference between 3.7 and 3.7.1.

It is a quick fix until the compatability issue gets resolved. Hope this solves your problem too.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

It is in no way related to Logbook Pro, no problems have been noted here and I've been using 3.7.1 since release. There are reports popping up now that ActiveSync 3.7.1 is having problems with synchronization and it's something on the Microsoft side, not NC Software side, so there's nothing we can do to resolve this.

I'm glad you found a link to share on this to help those that need to regress. I guess this also follows the motto of 'if it works, leave it alone' hence, if 3.7 is working for you, don't upgrade ActiveSync. But again, I've seen no problems with it here in development on multiple handhelds.

Thanks for your help, glad we can get a solution to this problem.

 

pacemaker323

New member
Joined
Nov 14, 2003
Messages
2
That worked!!! Thanks for the link, Wilsonm. Active Sync 3.7.1 definitely does not work. I did everything the same with 3.7 and it's working now. Thanks!
 

donaldbm

Active member
Joined
Oct 3, 2002
Messages
43
Hi Neal,
I couldn't find MDAC 2.6 SP2 but the link you gave took me to MDAC 2.8. The download has the following message though. 'Microsoft recommends that you first test your application with MDAC 2.8 in a test environment to make sure that you are aware of any compatibility issues before you decide to use or to upgrade to MDAC 2.8.' Not being the most computer literate guy in the world this sort of message scares me a bit. What is MDAC and JET 4?
 

wilsonm

Member
Joined
Apr 5, 2003
Messages
7
Hi everyone,


The new work-around published by Mr. Weston and Neil in this forum worked perfectly in solving this problem.


I recommend for those who have not given a try yet and wish to upgrade to Active Sync 3.7.1 (the only one now available) to use the alternate database setup method posted.


It is really simple, and only one step has changed. Just make sure you install it exactly as it is instructed to ensure you won't have any further problem.


Regards,


Mark


Quoted:
Hello, all! I thought I'd share this with you since I know first hand how frustrating this whole ActiveSync thing can become!

I've found a solution to this problem with ActiveSync 3.7 and 3.7.1, as pertains to Logbook Pro and Pocket PCs (PPCs). You'll have to create a link between your logbook file and your PPC manually. Only one step changes...Step 6, bullet 1, add alternate method to read: Within Activesync right click on the Pocket Access Information Type and select SETTINGS. In the box that opens, click ADD.
At this point you'll be at the same point, but via a different (manual) approach. So, you'll now need to simply accomplish the remaining steps (beginning with Step 6, bullet 2) exactly as written in NC Software's installation guide.
I don't know why this is, but Activesync is a real beast to conquer in many ways.

I also advocate the President's recommendation to ensure your JET4 and MDACs are up to date first.

Happy Computing, and Safe Flying! Or is it the other way around? :)

CW
 
Top