No data sync and error message on LOG STATS

danprov

Member
Joined
Dec 15, 2006
Messages
5
Hi


My evice is a HP IPAQ 6315

On my computer (win XP) I have installed LogbookPro 1.10.26 and on my PDA there's LogbookPro PCC 1.10.16.
Both Programs are running well.
ActiveSync 4.2 is running well.
Ports in Firewall are open (RAPI and the other Activesync-Stuff)

I have 2 major issues however:



1) Everything says it sync ok I have no error message but nothing appears in LogBookPro spreadsheet n the PC. (The data has been corrrectly entered and "accepted" on the PDA)

2) When I try to access LOG STATS on the PDA I have the following error message text:

LogBook Pro.exe
InvalidCastException
Microsoft.Visualbasic.CompilerServices.Conversions.ToInteger
Microsoft.Visualbasic.CompilerServices.Conversions.ToInteger at i.k() at i.g()
Microsoft.Visualbasic.CompilerServices.Conversions.Tointeger
System.Windows.Forms.Form.OnActivated()
System.Windows.Forms.Form.WnProc()
System.Windows.Forms.Control._InternalWnProc()
Microsoft.AGL.Forms.WL.SetVis()
System.Windows.Forms.Control.set_visible
at j.n()
at k.am()
System,Windows.Forms.Control.OnClick()
System,Windows.Forms.Button.OnClick()
System,Windows.Forms.ButtonBase.WnProc
System,Windows.Forms.Control_InternalWnProc()
Microsoft.AGL.Forms.EVL.EnterMainLoop()
System,Windows.Forms.Application.Run()
at j.h()

And the logBookPro PPC shuts off.

Any help please?
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

I suggest uninstalling "Logbook Pro Pocket PC Companion" from your PC's Control Panel Add/Remove programs area. This will also bring up ActiveSync's add/remove programs dialog, select "NC Software Logbook Pro" then click Remove. On the PPC open up File Explorer and delete /Program Files/Logbook Pro and also /My Documents/Logbook Pro. This will ensure it is purged from the device.

Download and install Logbook Pro Pocket PC Companion again, and if you want you can choose the option WITH .NET CF2 and see if this resolves the issue.
 

danprov

Member
Joined
Dec 15, 2006
Messages
5
still unable to get my flight log sync

Hi

I did as you said . I can now see my Log Stats but I am still not capable to import the "Flight log" data entries from the PDA to the PC. I have all the correct messages that everything sync is OK but nothing appears in Logbook Pro on the PC. Also I can't sync data entered in the "Certificates" category but "Ratings" and "History" work well...

help please
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
I believe the issue is just how you're entering data. Try this test:

Go to certificates, if none exist, add the data and then click the SAVE icon. Click the NEW icon (far left on toolbar) and add more data, then again click SAVE. Click OK on the top right to close out of this area.

Do the same with the Flight Log area. If none exist, add data to include Date, Type, Ident, Route, and Duration, then click SAVE. Click NEW then add another record, click SAVE again. Click the "OK" at the top right to go back to the main switchboard screen.

Tap the menu File..Shutdown and then launch the PDA Wizard to sync in the Certificates and Flight Log data and see how it goes this time around.
 

danprov

Member
Joined
Dec 15, 2006
Messages
5
no changes

I did as mentionned but no change, still cannot sync flight log and certificates
 

danprov

Member
Joined
Dec 15, 2006
Messages
5
Problem solved

I finally discovered what was wrong. My settings in Logbook Pro on the PC prevent a flight log entry without value in the "duration" field. I removed that setting and was able to see my log entries transfered from Logbook Pro PPC but the field "duration" was always empty. Even if I had put a value in it on the Pocket PC.

My computer Windows XP uses the comma "," as a "number decimal separator" instead of the dot ".

I discovered that Log book Pro do not recognize the comma. I changed the setting in Window XP to use the dot instead and now everything works fine :)

Thank you very much for all your help and support. It was appreciated. You did a great job!

Happy Holidays!

Dan P.
 
Top