PDA requirement

Tak

New member
Joined
Jan 31, 2006
Messages
3
Does anybody know logbookpro companion software works on iPAQ1910? I have iPAQ1910 and this one use pocketPC 2002 Pro.I tried to install demo software but having problem.
 
Top