Pocket PC Software doesn't run.

PilotFlying

Well-known member
Joined
Jul 17, 2006
Messages
72
Location
Toronto, ON
I've installed the Logbook Pro and Logbook Pro Pocket PC Companion software on both PC and Pocket PC, respectively. Software works great on PC, but will not even run on Pocket PC. I will click the icon, but nothing happens. I've activated the licences for both PC and Pocket PC software through the PDA menu in PC software.

Anyone have any ideas what is causing this? The documentation says to actuvate licence in BOTH PC and Pocket PC software, but how can I activate the Pocket PC software if it won't run?

Any help would be greatly appreciated!
 

PilotFlying

Well-known member
Joined
Jul 17, 2006
Messages
72
Location
Toronto, ON
Great! That fixed the problem, thanks. The Logbook Pro software now works on the Pocket PC; however, it still won't sync data with the PC. The PDA Syncronization Wizard screen shows 0 pending entries. I have tried the ActiveSync troubleshooting steps, but still no joy.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Launch Logbook Pro on your Pocket PC. Go to Certificates, add one test entry, tap the SAVE disk on the bottom toolbar.

Go to the Logbook area. Add a new flight, when done tap SAVE, then tap NEW (the far left icon on the toolbar) and then enter another flight, then again SAVE then close the dialog.

Tap the File menu then choose the Shut down option.

Launch Logbook Pro on the PC and run the PDA Wizard, see if you see the data available to sync in.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Please try the following:

Uninstall "Logbook Pro Pocket PC Companion" from your Windows Control Panel Add/Remove programs area. This will also bring up the ActiveSync Add/Remove programs area, when you see that dialog, click "NC Software Logbook Pro" then click the Remove button.

On your Pocket PC, using File Explorer, delete these two folders:

/My Documents/Logbook Pro
/Program Files/Logbook Pro

(Of course, only delete the Logbook Pro sub-folder)

After that is completed AND you verified the .NET COMPACT Framework v2 is installed on your device (see http://www.logbookpro.com/netcf2.asp for details) reinstall the latest download of the Logbook Pro Pocket PC Companion from our web site.

After this is completed and you confirmed also that Logbook Pro for Windows 1.10.24 is on your PC and you also have the Microsoft .NET Framework 1.1 installed on your PC, start then close Logbook Pro, then launch Logbook Pro on the Pocket PC.
 

PilotFlying

Well-known member
Joined
Jul 17, 2006
Messages
72
Location
Toronto, ON
OK... done. Still nothing.

A side note - which may or may not be related to this problem - is each time I start Lofbook Pro on the PC and open the PDA Wizard, I have to open the Wizard three times before it works correctly (showing the queued data to sync). The first attempt at opening does nothing. The second shows the screen where it asks to activate (although I have selected to skip this page in the future). The third gives me the queued date, which thus far always shows *** No Data to Sync ***. The PC Companion is licensed, because it shows that it is licensed to my name on the startup screen. The PC version is also licensed.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
So you are able to run Logbook Pro Pocket PC Companion on the PPC, go to "Logbook" and add a flight? This flight contains a Date, Type, Ident, Route, and Duration? After this required info is saved, tap the SAVE disk icon to save the info, then run the PDA Wizard in Logbook Pro PC edition.
 

PilotFlying

Well-known member
Joined
Jul 17, 2006
Messages
72
Location
Toronto, ON
Yes, I am able to enter a flight with all the above fields and save the data, either with the save icon or by pressing OK and pressing save on the pop-up dialog. But still, there is no data recognized when syncing to the PC.
 

PilotFlying

Well-known member
Joined
Jul 17, 2006
Messages
72
Location
Toronto, ON
For the record, I'm running Logbook Pro v1.10.24 and PPC Companion v1.10.16 on a Toshiba e830 with Windows Mobile 2003 SE. .NET COMPACT Framework v2 is installed.

PC is running Windows XP, all updates, and .NET Framework 1.1 is installed.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
I'd like you to make test entries in the Certificates, Ratings, History, and Logbook area. Then copy the two files you'll find on the PPC in /My Documents/Logbook Pro to your PC and submit the two files in a support ticket. We'll pickup from there.
 

PilotFlying

Well-known member
Joined
Jul 17, 2006
Messages
72
Location
Toronto, ON
Just to keep you updated, I was finally able to resolve my syncing (or lack thereof!) problem by reverting to ActiveSync 3.8 after talking to a friend who had the same problem and found ActiveSync v4.X to be the issue. Unfortunately, this was not an easy task, as neither of us were able to simply uninstall v4.X and reinstall v3.8 without a complete system format and reinstall.

So, 5 painstaking hours later, everything is now operational, and I look forward to using Logbook Pro to its full potential. It appears as though Logbook Pro and ActiveSync v4.X are not compatible with ALL devices. Anyone out there considering the upgrade may want to keep this in mind.
 
Top