Universal Report

rptrain

Member
Joined
Jun 8, 2002
Messages
6
here's a weird one...

i created a custom report based on the MGOEnt universal report. i then tried to put the 'number of approaches' field in the 'INSTR APPR' column (makes sense). In the column labeled 'Flight Simulator' by default (i.e the last column under 'Conditions of Flight&quot/forums/emoticons/wink.gif, I want to put one of my Custom Time fields.

Strangely enough, when I did this these two fields were swapped in the generated report. The column titles were where they should have been, but the 'INSTR APPR' column had my custom time field and the column that should have had my custom time had the number of instrument approaches for that flight.

what the heck?

if i just swap the two fields around in the report designer, it comes out OK, but this doesn't make any sense to me. especially since the approaches field is an integer number, and my custom time field is in tenths.

appreciate the help.
 

rptrain

Member
Joined
Jun 8, 2002
Messages
6
glad it wasn't just me!

thanks for looking into this. are there any caveats to beware of with my workaround? i haven't tried printing the report yet.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
The bug was found, and you won't have to change anything as it's a problem in the report itself and not the designer. When v1.7 comes out, it will correct itself with no change required from you.

The problem is that columns 13 and 17 as swapped for data fields. You know these two are swapped, so if you need your report now, you can just set them backwards to make it work, make sense? Set Inst App column to read the data you wanted in the other column, and vice-versa.

Good catch! Thanks!

Neal Culiner
NC Software, Inc.
support@nc-software.com
 
Top