Auto-duration after importing?

Singletracker

New member
Joined
Oct 17, 2007
Messages
2
Hi! I'm in the process of importing my custom Excel logbook into Logbook Pro. My airline logs all have In and Out times for each flight. How do I get LP to calculate and auto-fill the Duration of these newly-imported flights? I have the "Auto-duration by" option set to "OUT to IN".

Thanks!
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,572
Location
VA
Hello,

The Automatic Duration calculation only fires when a change is made in the data entry area to the respective out/in or takeoff/landing as set in the Options...Flight Log area. It does not work on an Import as it assumes your duration is already calculated and changing that would not typically be desired. So you will have to go through and make a change to your out/in times and probably need to clear the duration value prior to triggering the auto-duration calc.
 

Singletracker

New member
Joined
Oct 17, 2007
Messages
2
OK, that's fine... all of my original Excel logbook pages have a duration as well. Trouble is, when I was importing, I selected the duration column to be imported as LP's "DURATION", but the end result was zero duration for all flights. Hmm. I figured that maybe LP ignored my duration because the IN/OUT times were in HH:MM, but duration was decimal. Fortunately, my original logbook had both decimal and HH:MM, so I tried importing again, but this time selected the HH:MM-formatted duration column. This time, I got an error message, telling me that my duration column was in the wrong format. Any ideas? (PS Thanks for the quick response on my original question!)
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,572
Location
VA
When you first run the Import Wizard, the lower left section you have to set the format of your times. So if your incoming format is decimal, i.e. 1.5 for one and a half hours of flight, make sure you set that option properly. On the second Import Wizard step check the checkbox at the top that the first row contains column headers, then map your columns and try again. If you are unable to resolve this send me your data via a support ticket (zip compress your data file first) and I'll gladly take a look at this for you.
 
Top