Catastrophe! Has anyone else had this happen to them?

Status
Not open for further replies.

kd2473

Member
Joined
Jun 26, 2006
Messages
12
Help help!! Has anyone else had this situation happen to them and if so, what did you do??
My partner and I have the logbook on 2 computers - he's master and I'm clone (mainly to speed up the painful task of manually inputting years of logs!). All worked fine with the sync-ing until last week when the sync wouldn't work, and couldn't input with CSV file either. Basically the clone import tried to make itself the master and there was some data corruption.
After support from Neal, he told us to force a data rebuild on the master... which we did yesterday with catastrophic results. The old backed up data can no longer be accessed (if we go in through the Logbook/Archive/Restore it throws up a choice of 4 - update/backup/sync/quit - rather than the usual screen) and if we go in through the computer harddrive to the BAK file it says Invalid File. The logbook currently being displayed is utter gibberish, with doubled flying hours etc.
So it currently looks as though we may have lost some 6,000hrs of flying, with a v important interview coming up...
Does this ring any bells for anyone? Can anyone offer any solutions? Neal isn't back until tomorrow and we are completely desperate!
Thanks
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

I'm checking in while waiting my flight in the airport. I have no heard of this issue happening in over 9 years of Logbook Pro, nor have we had a scenario such as you are doing with two separate users sharing one data file, it sounds like you had a corruption on the computer causing problems. Rebuilding the data structure should not have caused any problems and I will look at your support ticket upon return for the files I requested.
 

kd2473

Member
Joined
Jun 26, 2006
Messages
12
Thanks Neal, as you can tell we're a bit stressed so I thought it worth seeing if anyone else had reported the same thing.
I mailed you a zip file last night with my BAK/CSV/LBK clone files and Paul's CSV (in its post-rebuild state) and pre-rebuild BAK file (which he can't now access/restore) - I am praying you'll be able to do something with them!
Please let me know if there is any other information you need from us and we'll give you all the help we can to try and resolve this.
 

kd2473

Member
Joined
Jun 26, 2006
Messages
12
Sorry Neal, one more thing that might assist. As I said in one of the early emails last week, Paul has lost the ability to access the video tutorials in recent months, which we thought was a bit odd, and now we are wondering if this glitch might be related to the recent problems? He downloaded his version through Sporty's (and I used the CD Rom with the same unlock code).
Once again, thanks for any help you can give us.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

If that is the case, it is not a Logbook Pro issue but a problem with the computer in question. It sounds like you have an issue with Windows OS that is causing these issues.

As it is counter-productive to communicate through both forums and support ticket, let's stick to the support ticket which I will be reviewing first thing in the morning.

We'll get you taken care of, don't worry!
 

kd2473

Member
Joined
Jun 26, 2006
Messages
12
Neal,
I have emailed the files over to you again since the first email obviously didn't reach you - can you confirm that you have received them please? Thanks
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
I don't show any replies to your ticket, your files may be too big and your upload is timing out. Send any .BAK files one at a time, making a new reply to your ticket for each file. If you are sending any files ending in .LBK, they must be compressed first. You can ZIP compress (use Maximum compression, not normal compression) with a program such as Winzip. Again, just send one file with each reply to your existing support ticket. Then send any CSV files as required, I recommend also ZIP compressing those.
 

kd2473

Member
Joined
Jun 26, 2006
Messages
12
Neal, I hope you got Paul's email on this earlier - he can't open the attachments you sent through. I have just now checked it on my computer (clone) and I have the exact same problem - the BAK is 'invalid file' and the logbook takes me onto that 'update' screen with the 4 options that just take us both round in circles. Finally, the HTML file shows the corrupt data (far too many hours etc).
What on earth is going wrong?!
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello Katherine,

The data is not corrupt, if you are showing too many hours, it sounds like you imported data that may have already existed. You will need to go to a prior backup or remove the data that is causing the totals to be incorrect. If the attachment system added a zip to the end of the file, i.e. filename.bak.zip, rename the file to end in .BAK only.

As I requested previously, please use only one method of communication, i.e. your support ticket. Having two separate paths of conversation will cause confusion.

Thank you.
 
Status
Not open for further replies.
Top