More Copy & Paste issues.

jfreas

New member
Joined
Nov 18, 2004
Messages
2
Ever since I upgraded to v1.9.7 I am unable to Copy, Cut or Paste anything into or out of my logbook! I have tried keyboard combos (CTRL-C, etc.), right click menu selection and pull-down menu selection of the functions and the results are the same; nothing happens.

I have tested to see if anything has actually been copied out of the logbook by pasting into Notepad and nothing has. Anything that had previously been in the copy scratchpad is still there, but is not replaced by a copy or cut command from Logbook Pro. Likewise, any attempt to paste into Logbook Pro fails. This is the case for both the Remarks column and the Route column. Interestingly it seems like LBP is recognizing the command because it responds with the little finger snap sound, but doesn't actually perform the requested function.

I did not have this problem before upgrading.

I am running on Windows XP Pro w/SP2. Thanks for any help you can provide.

-John
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,572
Location
VA
John,

Yes, the clipboard buttons/menu options have been disabled as a result of fixing the 1.9.6.5 bug. However, keyboard shortcuts should/do work, that is the work around. For example, go into the Spreadsheet Style log, select text in the Remarks column then press CTRL+C to copy it. Click at the end of the Remarks where you want to insert the test and press CTRL+V to paste.

The issue is minor and does not warrant a hot fix at this time. I apologize for the inconvenience, but this 'only known bug' can be overcome with keyboard shortcut keys.

Thank you for reporting this. We are aware, it will be fixed in the next update.

 

jfreas

New member
Joined
Nov 18, 2004
Messages
2
I'll be darned.


I could have sworn that I had been using CTRL-C before without success, but I just tried it again and it works as you describe.


Thanks.


-John
 

Don

Member
Joined
Nov 15, 2004
Messages
10
I'm not sure what I'm doing wrong, but I am trying to fix some airport destinations that didn't import. I'm trying to paste an aiport appended to many of entries, but it's not working to cut and paste it at the end of an entry. It seems to be interfering with the pull down menu of airports that we previously/manually entered.
 

Don

Member
Joined
Nov 15, 2004
Messages
10
It's weird, but I'm using CTRL C & V, and using the cut-paste icons the on menu bar, but something is not working properly.
 

Don

Member
Joined
Nov 15, 2004
Messages
10
Just as an update, I've been fixing the importing of my logbook in the 'route' column. I still can't cut and paste. Everytime I think I copy something, I click into the route menu but all these pull-down options appear that were previously entered in other fields, but it doesn't let me paste in/append anthing. For example, when I imported my file, I was able to have LBP insert in the route column 2 entries. One 'from' airport and some other airport during a 4 leg day. So I am trying to go back and paste in the 'return' airport. So my real entry would be OAK-STS-CCR-OAK. When I imported, it would be just OAK-STS. So I'm going back and trying to paste '-OAK' to save me some time, but the pull-down selections just appear and no pasting is allowed.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,572
Location
VA
The drop down list will populate itself after the row as been updated which occurs when you click off the row. If you can type -OAK on the end of your existing route, you should be able to paste as well. You can't edit the entries in the drop down list itself, only the entry part of the field. Again, if you can type manually, there is no reason paste wouldn't work.

 

Don

Member
Joined
Nov 15, 2004
Messages
10
Neal, I know it doesn't sound logical, but something is not letting me cut and paste. I just tried to type in an airport and paste it one some other row, but it is still not working. Anyway, I'm finished entering my old data and I'm looking forward to the time savings that LBP will give me on all future flights. Is there anything in the regs that states that a written, hard copy is necessary? I like the digital only logbook. Thanks.

BTW, I am watching the video tutorials. I understand that it was made with the windows 2000 interface, but on WinXP, I can't get the icons to show text and icon. Is that normal?
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,572
Location
VA
Please confirm the exact field you are attempting to PASTE into so I can test. Also, is this the spreadsheet or windows style entry area?

As for the text and icon, this is from an older version which is what the video tutorials represented at that time and with the new user-interface, that option is no longer available as the smaller toolbar is already used.

 

Don

Member
Joined
Nov 15, 2004
Messages
10
Neal, this is the weirdest thing. It's working today all of a sudden! It was in the route-of-flight field. I'm positive I did everything just as before, but something made it work today. I was playing around in explorer mode, and then went back to spreadsheet style. I just type
'-OAK' and copied it, this time it pasted everywhere! I'm positive it didn't work the first couple of weeks.
 
Top