• NC Software is having a Black Friday Sale Event thru December 4th on Logbook Pro, APDL - Airline Pilot Logbook, Cirrus Elite Binders, and more. Use coupon code BF2020 at checkout to redeem 15% off your purchase. Click here to shop now.
  • Logbook Pro for Apple iOS version 8.0 is now available on the App Store. Major update including signature endorsements and dark/light theme support. Click here to install now.
  • NC Software is proud to announce the release of APDL - Airline Pilot Logbook version 10.0. Click here to view APDL on the Apple App store and install now.

Build 232 problem

phishhman

Member
Joined
Nov 15, 2001
Messages
21
Location
Denver
I have been having some problems. First, I put a shortcut to LBP on my quicklaunch bar. It worked fine for quite a while, but lately, when I click it, it wants to install the program again. The problem goes away when I reinstall, but appears about a month or so down the road.

Second, I tried to run some reports, and the program hangs while processing the reports. It doesn't lock up, but it just never displays any reports. Graphs appear fine. Any ideas?

--Phishhman

It taks a big man to cry, but it takes a bigger man to laugh at that man.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,664
Location
VA
Please fill out the detailsin the USER CP (edit profile) area so I know what OS and Software Version you are running.

Logbook Pro uses the latest Microsoft Installer technology which is 'self-healing' meaning that if it sees something other than the way it was installed, a corrupt file, something falling out of order, it automatically fixes it. Depending on how you are creating your shortcut you may be conflicting with this system. I'm not sure why this would be the case, but again, if you are left clicking then drag and dropping the shortcut Logbook Pro installed, it may recognize that and try to correct it. I really can't help much on this one.

As for the reports, the report DLL doesn't seem to be registered. I suggest uninstalling, rebooting, searching for lbRepts.DLL and delete it. Install the software again and see if that works. Make sure you are using the latest version from www.logbookpro.com (at this writing it's 1.6.232).

Version 1.7 should be out in a few weeks, so we'll have a new install anyways. If reports aren't critical, I suggest just wait for the new build, otherwise, the above procedure should work. There are no report functionality issues reported for 1.6.232.

Neal Culiner
NC Software, Inc.
support@nc-software.com
 
Top