LBP lock-up on start, part II.

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
I've been patiently awaiting a response to my second request for help with logbook pro (SPT-040707.15948 & SPT-040809.13401) since 8.9.04. As of today, 8.17.04, I haven't received any word from NC-Software about a fix. I've complied with every reqest that Neal/NC Software has made over the past five weeks, and yet I've not received any information on how I might fix the problem.

Neal, I have an up-to-date operating system - Win98 - that has no problems running any other software on my system (I spent over four hours over the weekend checking the functionality of each one). My system exceeds the minimum required system- as stated on the website. Whether or not you think Win 98 is "...probably one of Microsoft's worst OS's and is very fragile and succeptable to failure..." is immaterial, your software is supposed to run on it. Whether or not other Win 98 users are having problems is immaterial, I can not run LBP without it locking up.

I think that I've been very patient with this issue. I understand that some problems can not be fixed overnight, but require trouble-shooting/problem solving to fix. Wouldsome one at NC-Software work with me solve this problem and stop blaming my system/OS before you've actually tried to problem-solve.

Thank you in advance for your help.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Hello,

If you visit the AnswerTrack site and enter your ticket numbers, you will see my attempts to correspond with you, as well as the responses. Please contact support@nc-software and I will gladly continue to try and resolve the issue to the best I can. First please read this article and ensure your database drivers are up-to-date. Although the article is intended for the PDA users, the database drivers apply to Logbook Pro as well.

 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Thank you for your reply. Unfortunately your original replies did not reach my pop3 account, nor my MSN hotmail account. I have updated the MDAC and MS JET drivers as per the posting, but unfortunately this has not fixed the problem. I was unable to download the attachement from your 7.8 or 7.14 messages from the answertrack page (file not found error when clicking the attachment), please resend the attachment and I will try again.
 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Neal,

I've tried using the replacement .bak file that you sent. I tried restoring the .bak file on an already installed LBP and also on a fresh install of LBP. Unfortunately, neither attempt has fixed the problem. The program still locks up after the main program loads, but before the spreadsheet view opens. There is a small window of opportunity where I can access the top row of options/commands (File, Edit, etc) in which I am able to attempt to restore the .bak file. But if I miss this window, the program locks up and nothing is accessible. Any other suggestions would be greatly appreciated. Thank you.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
I'll e-mail you one other option. However, have you tried your logbook on another computer to isolate your PC as the culprit? Secondly, are you saying that the menu system is unusable as well as the spreadsheet style not working? What is the EXACT issue you are seeing happen to Logbook Pro in this situation?

 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Neal,





I'm on the road right now - at least until the end of the month and possibly untill the 16th ofnext month, so I won't be able to test on my desktop until I get home.


The menu system is locked out after start-up. There is a very short window of opportunity in which I can access the menu system (to attempt backup restoration, etc.), but after this "window of opportunity" the menu system is locked out.
 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Yes, LBP starts up normally. The splashscreen displays with jet sounds and all, LBP start normally with menu system displayed at the top and access to the menu system for a very short period of time. After this short period of access the system "locks-up". The menu system is still displayed at the top, but will not respond to mouse or keyboard commands. At no time during start-up or after will the spreadsheet view display.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Well, this is the first I've heard of this behavior in the history of Logbook Pro unfortunately! I'm not sure what other software/security applications you may be running, but I suggest uninstalling Logbook Pro, ensure any security/anti-virus software is NOT running when you reinstall. Since you have the BAK file I sent you, after uninstalling/rebooting/disabling Anti-Virus, DELETE the Logbook Pro folder in C:\Program Files. When reinstalling Logbook Pro, reinstall it to a different folder, not the default. For example, install it to C:\Logbook Pro instead of C:\Program Files\Logbook Pro as an example. Then restore your BAK file and see if that works.

Lastly, I assume you are running your data/BAK file from the hard drive, not a CD-ROM, or removable storage?

 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Ok, I've tried the above and the problem still exists albeit in a new form, perhaps this will give us a better clue as to where the problem lies.

Detailed Remove/Install Process:

1. Using InstallShield Wizard, Logbook Pro (LBP) is removed from my system.

2. Using Norton System Works Utilities (NSWU) Registry Management, all references to Logbook Pro are removed from the following: a. Local Registry b. Local .INI files c. Sytem .INI files d. Control .INI files e. WIN .INI files.

3. NSWU WinDoctor & Disk Doctor is run - no problems indicated.

4. MS Windows File Find is used to locate all references to LBP, which are then deleted.

5. Background Programs Unloaded or Paused: a. Task Scheduler b. Zone Alarm Pro c. Norton Anti-Virus d. Spy Sweeper.

6. Laptop restarted.

7. Fresh Installation of LBP to C:Logbook Pro

8. Product Key entered and access to LBP is granted.

9. Restore option selected: a. Restored backup file restored to TEMP folder in C:Logbook Pro. b. Replace current LBP file with backup c. 'Backup Restored' indicated by LBP.

10. Dialog Box 'Logbook Pro will now be updated to take advatage of several new features': a. OK selected - 'Building New Structure...Please Wait' appears, 100% indicated, then program 'hangs' requiring three key to unload program. b. Cancel selected - LBP unloads, Windows desktop appears, LBP restarted and steps 1-10 have to be repeated (ie. Cancel option appears to do nothing and the whole process of restoring the backup must be repeated).
 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Steps 5 & 6 need to be swapped:

Should Read:

5. Laptop restarted.

6. Background Programs Unloaded or Paused: a. Task Scheduler b. Zone Alarm Pro c. Norton Anti-Virus d. Spy Sweeper.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
You should not be seeing #10 using the .BAK file I sent you. There is something locking the data file or making it read-only triggering an update system. It sounds like you have something conflicting with all those security programs that is interfering with Logbook Pro. I also do not recommend programs such as SystemWorks that end up doing more harm then good. I'm sorry I do not have options to help in this case. There is obviously something with your PC and software that is interfering. There is a known issue with the background updater in 1.9.6.5 and Zone Alarm Pro that may cause the program initial startup to be delayed, however it doesn't appear this is the case with your system as you are seeing the splash screen right away.

 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
The security programs are unloaded/disabled during the install and then again when trying to run LBP. I'm not sure how this should interfer with LBP, please explain. Also, the previous version of LBP ran just fine with these programs installed and running.
 

Neal Culiner

Founder, President
Staff member
Joined
Nov 14, 2001
Messages
12,574
Location
VA
Are all Windows Updates including the latest Internet Explorer 6.x installed? I again do not have any other options to offer as I the software is tested on all OS's prior to releasing any updates. Windows 98 is the first to get tested and there are no problems noted with a clean Windows 98 OS.

 

hiflyer747

Member
Joined
Aug 9, 2004
Messages
15
Yes, my system is up to date according to MS. My problem sounds exactly like the problem posted on 7.28.04 entitled 'DEMO version locks up...100% CPU utilization', so I know that I'm not the only one having this problem. I hope that you will take a day or two to explore other options and continue supporting your paying customers.

Again, the security programs are unloaded/disabled during the install and then again when trying to run LBP. I'm not sure how this should interfer with LBP, please explain. Also, the previous version of LBP ran just fine with these programs installed and running.
 
Top